×

To enhance security, Multi-Factor Authentication (MFA) is mandatory for all HL7 users. More information

 

Ballot the FHIR Bulk Data IG (ONC/Grant Project)

Basics

Ballot the FHIR Bulk Data IG (ONC/Grant Project)

1497
Vendor Contract


FHIR Implementation Guide

Implementation Guide

Details

The existing FHIR standard is an excellent method to make atomic healthcare data accessible via API. In addition to atomic data for individual patients, a major use case in health care is the transmission of bulk data among institutions and across data warehouses or other interfaces en masse. The need to support population level data transfer in FHIR is already here.

Currently the core FHIR specification contains a reference to the NDJSON format (https://www.hl7.org/fhir/nd-json.html) received through the asynchronous pattern (https://www.hl7.org/fhir/async.html). However the core specification requires additional clarity to define more specific usage when data is transmitted between organizations for real world use cases. Specifically this Implementation Guide will add the ability to export groups of patients, only recent data since a date, and specific examples for usage in the U.S. market.

To that end, this Implementation Guide will be written to provide guidance for enabling secure bulk data transfer for FHIR resources. The guide will define the application programming interfaces (APIs) through which an authenticated and authorized clients may request a bulk data export from a server, receive status information regarding progress in the generation of the requested files, and receive these files securely. The guide will be utilizing the following standards:

HL7 Fast Health Interoperability Resources (FHIR) Release 2, 3, 4, https://www.hl7.org/fhir/

Newline-delimited JSON(NDJSON) http://ndjson.org

The OAuth 2.0 Authorization Framework, RFC6749, https://tools.ietf.org/html/rfc6749

The JavaScript Object Notation (JSON) Data Interchange Format, RFC7159. https://tools.ietf.org/html/rfc7159

Transport Layer Security (TLS) Protocol Version 1.2. RFC5246). https://tools.ietf.org/html/rfc5246

The OAuth 2.0 Authorization Framework: Bearer Token Usage, RFC6750. https://tools.ietf.org/html/rfc6750


Today FHIR applications are also built for reporting, analytics, population health, and other use cases which look at patients in aggregate. FHIR’s current APIs are suited to enable access to a few patients at a time or make ad hoc queries but do not cover the bulk data transmission use case. The industry has an need to transmit batches of data for entire populations or cohorts from data systems to apps or other organizations for workflows like provider to payer reporting or data migrations between systems. Additionally regulation is pushing for more standardized methods for transmitting all health data and reporting on it.

As the data housed in health systems transitions to the FHIR standard, a standardized method to transfer FHIR server data in large tranches or entire data migrations is needed. To facilitate data transfer between FHIR servers and client applications or other systems, a more technically applicable method for bulk data transfer is required.



STU 3 of the IG to be published May 2024 Prepare all necessary ballot documents (PSS, NIB, content, etc.) and gather approval from the following HL7 groups - Target: March 15, 2019: - FHIR-Infrastructure - Security (cosponsor) - ARB - Infrastructure SD - Technical Steering Committee Submit Final Content for ballot - Target: March 24, 2019 Complete Ballot Reconciliation - Target: June 28, 2019 Meet with FMG to make the Go/No Go Decision to re-ballot IG in the September 2019 ballot cycle - Target: June 28, 2019 Deliverable: FHIR Bulk Data IG updated and ready for re-ballot or publication - Target: September 18, 2019 Project End Date - Target: September 18, 2019


ONC Grant Project Page on the HL7 Wiki: http://wiki.hl7.org/index.php?title=ONC_Grant_Project_Page

How much content for this project is already developed? 100% Was the content externally developed (Y/N)? Yes, Boston Children’Hospital via an ONC grant project. Is this a hosted (externally funded) project? Yes

N/A

Quality Reporting Agencies, Regulatory Agency, Payors, Other (specify in Misc. Notes below),Local and State Departments of Health; Healthcare Institutions (hospitals, long term care, home care, mental health),EHR, PHR; Health Care IT; HIS


The Bulk Data will support existing efforts by healthcare systems and payer organizations as they develop standardized methods of transmitting FHIR data among their data stores. US governmental agencies (e.g., Centers for Medicare and Medicaid Services (CMS)) are considering transitioning existing claims data from current Claim and Claim Line Feed (CCLF) files to use the FHIR standard and require reporting data between provider and payor data to be facilitated by the FHIR spec. Although CMS has not finalized a requirement to use FHIR for this data transfer and there is no set date for such a transition, the FHIR Bulk Data IG will support necessary testing to provide sufficient evidence to support any such future decisions and guide the rest of the FHIR community along the way.

Flat FHIR

N/A



No

2026 September: Security voted to remove cosponsorship as the security component is no longer a part of bulk - it moved to SMART App launch. 2025 December: TSC approved an STU Publication Request for HL7 FHIR® Implementation Guide: Bulk Data, Edition 3 for two years 2021 December: TSC approved STU Publication Request for HL7 FHIR IG: Bulk Data Access IG, Release 2 for two years 2021 March: B. Marquard and D. Gottlieb submitting STU R2 for ballot in 2021 May ballot cycle. March 11, 2019 TSC Call: TSC discussed the sponsorship transfer issue (from FHIR-I to ITS) and the discussion resulted in the decision that FHIR-I was the correct sponsor. For FHIR IGs and FHIR Profiles, what product version(s) will the profiles apply to? R2, R3, R4 Other: Federal Healthcare Agencies (e.g. CMS) Contract Start Date: January 15, 2019 Contract End Date: September 18, 2019 Contractor Contact Information: CareEvolution - Ricky at 1up dot health
Organization & Realm

Universal

People

Dan Gottlieb, Brett Marquard



FHIR Infrastructure Work Group


Status & Dates

Active

STU - Test Period/Accepting Comments

01/30/2019

09/01/2027

2027 Sept WGM/Ballot

01/01/2027

2027 Jan WGM/Ballot

2025 Sep Ballot Cycle Info: STU Ballot results: Met basic vote requirements. 0 Negatives to reconcile Document Name: HL7 FHIR Implementation Guide: Bulk Data, Edition 3 2021 May Ballot Cycle Info: STU Ballot results: Met basic vote requirements. 23 Negatives to reconcile Document Name: HL7 FHIR Implementation Guide: Bulk Data, Release 2 2019 May Ballot Cycle Info: STU Ballot results: Met basic vote requirements. 29 Negatives to reconcile Document Name: HL7 FHIR Implementation Guide: Bulk Data, Release 1
Approvals

03/18/2019


Not Needed


All Received




System Info






09/28/2026

Anne Wizauer