×

To enhance security, Multi-Factor Authentication (MFA) is mandatory for all HL7 users. More information

 

FHIR Bulk Data Implementation Guide (PSS-2815)

Basics

FHIR Bulk Data Implementation Guide (PSS-2815)

1970
Ballot - STU

FHIR

FHIR Implementation Guide

Implementation Guide

STU
Details

Original Scope from 2019 Approved PSS: The existing FHIR standard is an excellent method to make atomic and small sets of healthcare data accessible via API. In addition to atomic data for individual patients, a major use case in health care is the transmission of bulk data among institutions and across data warehouses or other interfaces en masse. The need to support population level data transfer in FHIR is already here.

The core FHIR specification describes an asynchronous request pattern ([https://www.hl7.org/fhir/async.html]). This Implementation Guide will define secure FHIR export Operations that uses this capability to provide an authenticated and authorized client with the ability to register as a backend service and retrieve any data in a FHIR server, data on all patients in a server, or data on a group of patients while optionally specifying data since a certain date.

 The guide will utilize the following standards:

  •  HL7 Fast Health Interoperability Resources (FHIR) Release 2, 3, 4, [https://www.hl7.org/fhir/]
  • Newline-delimited JSON(NDJSON) [http://ndjson.org|http://ndjson.org/]
  • The OAuth 2.0 Authorization Framework, RFC6749, [https://tools.ietf.org/html/rfc6749]
  • The JavaScript Object Notation (JSON) Data Interchange Format, RFC7159. [https://tools.ietf.org/html/rfc7159]
  • Transport Layer Security (TLS) Protocol Version 1.2. RFC5246. [https://tools.ietf.org/html/rfc5246]
  • The OAuth 2.0 Authorization Framework: Bearer Token Usage, RFC6750. [https://tools.ietf.org/html/rfc6750]
  • JSON Web Signature (JWS), RFC7515, [https://tools.ietf.org/html/rfc7515]
  • JSON Web Key (JWK), RFC7517, [https://tools.ietf.org/html/rfc7517]
  • JSON Web Token (JWT), RFC7519, [https://tools.ietf.org/html/rfc7519]
  • Assertion Framework for OAuth 2.0 Client Authentication and Authorization Grants, RFC7521, [https://tools.ietf.org/html/rfc7521]
  • JSON Web Algorithms, RFC7518, [https://tools.ietf.org/html/rfc7518]
  • JSON Web Token (JWT) Profile for OAuth 2.0 Client Authentication and Authorization Grants, RFC7523, [https://tools.ietf.org/html/rfc7523]
  • OAuth 2.0 Dynamic Client Registration Protocol, RFC7591, [https://tools.ietf.org/html/rfc7591]

Original Need from 2019 Approved PSS: Today FHIR applications are also built for reporting, analytics, population health, and other use cases which look at patients in aggregate. FHIR’s current APIs are suited to enable access to a few patients at a time or make ad hoc queries but do not cover the bulk data transmission use case. The industry has an need to transmit batches of data for entire populations or cohorts from data systems to apps or other organizations for workflows like provider to payer reporting or data migrations between systems. Additionally regulation is pushing for more standardized methods for transmitting all health data and reporting on it.

 As the data housed in health systems transitions to the FHIR standard, a standardized method to transfer FHIR server data in large tranches or entire data migrations is needed. To facilitate data transfer between FHIR servers and client applications or other systems, a more technically applicable method for bulk data transfer is required.



- STU


http://build.fhir.org/ig/HL7/bulk-data

Boston Childrens's Hospital, 1UpHealth


Association/Goverment Agency,EHR, PHR Vendors,Health Care IT Vendors,Healthcare Institutions,HIS Vendors,Local and State Departments of Health,Payors,Quality Reporting Agencies,Regulatory Agency

Original Implementers from 2019 Approved PSS: 1)Boston Children’s Hospital 2)1upHealth 3)Google 4)Microsoft 5)CMS

Original Drivers from 2019 Approved PSS: The Bulk Data will support existing efforts by healthcare systems and payer organizations as they develop standardized methods of transmitting FHIR data among their data stores. US governmental agencies (e.g., Centers for Medicare and Medicaid Services (CMS)) are considering transitioning existing claims data from current Claim and Claim Line Feed (CCLF) files to use the FHIR standard and require reporting data between provider and payor data to be facilitated by the FHIR spec. Although CMS has not finalized a requirement to use FHIR for this data transfer and there is no set date for such a transition, the FHIR Bulk Data IG will support necessary testing to provide sufficient evidence to support any such future decisions and guide the rest of the FHIR community along the way.





No


Organization & Realm

Universal

People

Brett Marquard



FHIR Infrastructure Work Group


Status & Dates

Active

Active Project (Resources assigned to pjt)

09/29/2026





Approvals



Not Needed


Not Needed


Not Needed


System Info

291876

PSS-2815

09/29/2026

Jira Project Service